instalar emacs

Tengo la distribución Ubuntu 5.10 y quiero instalar emacs, para programar un poco y eso, he probado de las siguientes formas:

$apt-get install emacs

y

$aptitude install emacs

Y no se instala de ninguna forma.

Otra cosa, cual fue mi sorpresa al compilar un programa en C, no encontraba las librerías estandar de C, ¡¡Otra sorpresa de Ubuntu!!, si me puede ayudar alguien se lo agradecería mucho.

En resumen, que quiero instalar emacs y las librerías de C.

Gracias.

Comentarios

Opciones de visualización de comentarios

Seleccione la forma que prefiera para mostrar los comentarios y haga clic en «Guardar las opciones» para activar los cambios.
Imagen de antonioj

Con aptitude

Si usas aptitude, te recomendaría que lanzases la aplicación y luego buscases los paquetes que se llamasen emacs haciendo:

MAYUSCULAS + 7 pones emacs, aceptar. Al más puro estilo fool mode.

Y luego dando a la n, buscarás los paquetes que contengan emacs. Cuando tengas seleccionado el paquete que quieras instalar o bien te vas al menú y lo instalas o bien pulsas +.

Y para instalar el o los paquetes seleccionados: g y luego otra vez g.

La primera vez que pulses g, te detectará e intentará arreglar los posibles paquetes rotos que haya. Y la segunda los instala de verdad.

Espero que te sirva.

Un saludo

Antonio José

Un saludo

Antonio José

Imagen de magmax

Es que no es emacs

Prueba con esto:

# apt-get install emacs21

Y la próxima vez no te pongas nervioso :-D Cuando te pase éso, prueba con:

$ apt-cache search emacs

O, incluso:

$ apt-cache searh emacs | grep -i --color emacs

Miguel Ángel García
http://magmax.org

Imagen de Lk2

Yo diría que apt-get'eando

Yo diría que apt-get'eando el build-essential (no recuerdo el nombre del paquete, usa el método patentado de búsqueda "clutus" Laughing out loud

Es lo malo de simplicar tanto una instalación, que no te deja elegir si eres usuario, usuario programador .... etcétera Sticking out tongue

A quien ubérrima conífera se adosa, óptima umbría le entolda

Imagen de david.villa

librerías

¿Qué es lo que te falta en la librerías de C? ¿Cómo te has dado cuenta? Di que has probado y que error te ha salido.

No soy portavoz de ningún colectivo, grupo o facción. Mi opinión es personal e intransferible.

librerias C

yo tb tengo ese problema, pues cuando quiero compilar un programa q he creado con cc programa.c -o pro entonces me sale error por q no encuentra las librerias STDIO:H STDLIB.H etc.. entonces como puedo inatalar ese tipo de librerias de C para q me compile bien? porfa necesito su ayuda =S pls....

Imagen de cleto

Como instalarlo

Creo recordar que es apt-get install emacs21

De todas formas, cuando tengas problemas de este estilo puedes utilizar:
apt-cache search "palabra/as que quieres buscar"

Así te saldrán todos los paquetes relacionados con las palabras que buscas.

Un saludo!

************************
CLETO MARTÍN ANGELINA
Cleto.Martin@alu.uclm.es
************************