Para los que tengan Amd64 ...

¡Hola amiguetes!

Veréis, llevo como un mes con mi recién comprado amd64 intentando instalarle alguna distro que me de los mínimos problemas posibles ... y bueno, empecé a pegarme con Ubuntu, porque la conozco bien lo primero, y porque vi que tenían un CD específico para mi arquitectura.

El caso es que la instalo, y aparte de que no arranque el entorno gráfico por la tarjeta (una Ati), me da problemas raros ... todo empezó con no quererse poner el entorno gráfico en castellano ... teniendo todo instalado, todos los paquetes de language-pack-es y demás que vi. Me dí cuenta entonces que cada vez que hacía un apt-get o similar, o sencillamente dpkg-reconfigure locales obtenía un mensaje de error (un segmentation fault) proveniente del script locale-gen. Al abrir el script para buscar el problema, encontré que lo daba en una línea en la que invocaba a localedef, un ejecutable ... el cual, al ejecutarlo yo manualmente (por si acaso el script pasara mal argumentos o algo así), me siguió dando el mismo segmentation fault.

Así que me he renegado y he decidido que o bien, si alguien me da una solución, lo soluciono y a otra cosa mariposa, o bien me cambio a alguna otra distro (por ejemplo Debian) que no de problema alguno (o al menos no se lo de a los presentes que lean esto y quieran contestar). Así pues, os lanzo el guante:

a) ¿Alguna solución para localedef para que no de violaciones de segmento?
b) ¿Qué distro conocéis y tenéis corriendo sin problemas en vuestros amd64?

Comentarios

Opciones de visualización de comentarios

Seleccione la forma que prefiera para mostrar los comentarios y haga clic en «Guardar las opciones» para activar los cambios.
Imagen de tato

Hola compañero, te

Hola compañero, te comento:

Yo tengo un amd64 3200+, un disco duro sata de 160 gigas, una ati 9600xt y una soundblaster audigy 2 ZS (el pc tiene más cosas pero eso es loq ue quizás nos pueda dar problemas Smiling)

He probado mandrake (ahora mandriva), suse, gentoo, ubuntu y kubuntu.
Actualmente tengo kubuntu para amd64 y me funciona la ATI con aceleración 3d, los 5 altavoces de la audigy y me coge el sata. Ahora mismo me funciona todo el hardware sin problemas.

Pon que tarjeta tienes y a ver si puedo echarte un cable en algo. En www.ubuntu-es.org hay manuales muy buenos para poner las ATI a funcionar.

Enga un saludo!